逢甲大學

#發問 npm 問題~~

5月21日 19:37
最近在自學React 有關React App這部分! 官網上說要安裝 Node >= 10.16 和 npm >= 5.6 下載之後 npm不知道為什麼一直出現錯誤 估狗了都說是環境變數問題 但我試過都沒有用 請問有人知道怎麼解決嗎இдஇ
4
回應 6
文章資訊
共 6 則留言
國立臺灣大學
應該沒有npm 或 npm -v的指令 有的指令有你圖中 Usage:下面列的那些 (如 npm install) 使用node -v 會告訴你的node版本,有顯示應該就代表你安裝成功了。
原 PO - 逢甲大學
但我輸入 npm install 會跳錯誤
變成這樣இдஇ
國立臺灣大學
B2 要使用npm install等指令,你需要先在某個路徑底下,用npm init建立一個project。 它會叫你輸入一些你的project的基本資料,也可以使用npm init -y 快速建立。 所以如果你沒有一個project的話,就要進行我上面講的動作,如果你已經有project的話,就要在你的cli(黑色框框)切換到你的project的路徑,這樣才可以執行npm的各種指令。
原 PO - 逢甲大學
可是我npm init -y 沒辦法跑出東西 她會直接錯誤 一直跑出不是內部或外部命令
國立臺中科技大學
建議你找一個影片 跟著做
原 PO - 逢甲大學
謝謝上面兩位的回答 我剛剛找到這個方法解決了
😭😭😭😭😭