國立臺北藝術大學

#新手 #新手 python pyperclip 模組匯入(已解決)

6月11日 14:28
正在看Python自動化的樂趣 第六章要求我匯入pyperclip模組 - 我照著書本的教學上網站下載他的code 然後在終端機輸入 pip3 install --user r automate-mac-requirements.txt -- user 好幾個都安裝成功 但是跑到一半會出現以下的訊息 ERROR: Could not find a version that satisfies the requirement pyobjc-core==5.1.2 (from versions: 2.2b1, 2.2b2, 2.2, 2.3, 2.4, 2.5.1, 3.0.1, 3.0.3, 3.0.4, 3.1, 3.1.1, 3.2, 3.2.1b1, 3.2.1, 4.0b1, 4.0, 4.0.1, 4.1, 4.2, 4.2.1, 4.2.2, 5.0a1, 5.0b1, 5.0, 5.1, 5.1.1, 5.1.2, 5.2, 5.3, 6.0, 6.0.1, 6.1, 6.2, 6.2.1, 6.2.2, 7.0, 7.0.1, 7.1, 7.2, 7.3) ERROR: No matching distribution found for pyobjc-core==5.1.2 - 我上網查其他方法 有的講是直接複製pyperclip的資料夾到我的spyder下面 當我這麼做時,我run我的程式 import pyperclip pyperclip.copy('Hello world') pyperclip.paste() 從原本顯示 找不到pyperclip這模組變成 沒東西、沒反應 在console只顯示他跑了我的檔案 - 但我在Qt Console那邊卻可以跑出我要的東西 有點搞不清楚發生什麼事了 為什麼會有這樣的差別 - 嘗試在PyCharm做跟spyder一樣的事 或直接在setting安裝pyperclip模組 但PyCharm一樣都顯示找不到模組QQ
2
回應 4
文章資訊
共 4 則留言
國立交通大學
pip3 install - -user pyperclip 或是 把這個檔案裡面 automate-Mac-requirements.txt,pyobjc-core == 5.1.2 的 ==5.1.2 拿掉試試看
原 PO - 國立臺北藝術大學
B1 剛剛我嘗試在終端機輸入 pip3 install --user pyperclip 跑出的結果是 Usage: pip3 install [options] <requirement specifier> [package-index-options] ... pip3 install [options] -r <requirements file> [package-index-options] ... pip3 install [options] [-e] <vcs project url> ... pip3 install [options] [-e] <local project path> ... pip3 install [options] <archive url/path> ... no such option: -u -- 我嘗試第二個,然後pyobjc-core有裝成功,但是中間有個訊息是pillow版本好像有問題,說我電腦裡面的東西不可被取代(? 後來我就把後面==版本指定拿掉了 後來跑是沒出現什麼狀態異常資訊 但是我在spyder裡面跑 import pyperclip pyperclip.copy('Hello world') pyperclip.paste() 還是沒東西 -- 在想是不是我動到太多東西..
國立交通大學
B2 你直接看看 pip3 install pyperclip
原 PO - 國立臺北藝術大學
B3謝謝! 居然可以了!!!!